Bug: Ball python morph links missing on main page but still visible via filters

I’ve noticed that the hot links leading to some morph-specific sale pages are missing on the main browsing screen that displays all morphs. For example, the hyperlink for heterozygous Lace gene animals is entirely missing (not just the image, the hyperlink location doesn’t exist). If you search for heterozygous Lace animals on the filter page the animals reappear. Links for heterozygous and homozygous tri-stripe ball pythons are also missing. I haven’t gone through and checked every morph for missing links (some are fine) but some are definitely missing.

Images below show screenshots of the missing links on the browse page, followed by the results the filter shows when searched for individually.

image

image

1 Like

Hi @snowgyre
I just moved this in to a place that more of the staff would be likely to see it, and be able to help. I will tag @eaglereptiles to see if he has any ideas, or just to bring it to his attention. Hope you have a wonderful day :heart:

2 Likes

Thanks, I checked it again and the problem seems to have resolved itself. I’m not sure what happened, I checked the issue on two browsers. The missing links have returned. Perhaps I caught it during a DNS update?

image

1 Like

It may have just been a one time glitch in the system. That is why it is always a good idea to power down your phone, and turn it back on. And if that doesn’t help, try opening a different tab for morphmarket and closing the other one.
Sorry that is just what I do when testing for bugs and issues with the software for both the community and the market.

1 Like

No worries, I do the same thing and only reported it when I noticed it was happening on more than one device. It was probably a temporary network hiccup. In any case, glad it wasn’t a real bug. Thank you for the rapid responses, I appreciate it!

2 Likes

Happy to have helped! :grin:

2 Likes