Keyword Search Field Bug? [1684]

Hello. I noticed while using the filters option when searching through BPs, the keywords were prepopulated with coral glow and cinnamon. Not sure if this is a bug, I just noticed when I was both logged in and logged off. I use Microsoft Edge.

Edit: They are prepopulated in certain categories I am in. BPs, Boas, ect…



Can you provide further details? Browser, how you jumped to the filter (straight from splash page, while looking at an animal, etc) and the like??

@eaglereptiles @john

Flagging you two on this possible bug


Sorry for the delay. I would click the category like ball python, or boa, then click browse latest, then filter. I am on Windows 10, using Microsoft Edge. Seems to stop. I’ve personally never searched for coral glow cinnamon combos before. I didn’t notice until I was trying to sort them and all of a sudden all I was see was coral glow cinnamon combos lol.

1 Like

I actually noticed a similar issue on mine the other day, but it was with the chocolate morph. Kept automatically putting “chocolate” into the keywords.

I unfortunately didn’t get any screenshots, but I was looking for female banana combos and it was making it difficult.

I was using my iPhone 12 Pro on the most recent version of Firefox.


Thanks for reporting guys. @eaglereptiles will work on getting a reproducible sequence which is what we need.


Thomas said he cannot reproduce it so far.

What we need is for someone to give us steps starting with “click on home logo” (which clears everything) and then a series of a couple of steps to demo the problem. Thanks!!


It only happened that day. Hasn’t happened since then. Will report when it does it again.

I looked in my history, I was looking at harlequins in ball pythons categories, then went to filter, added Mojave under “Including” and that’s when coral glow cinnamon popped up in keywords. I then I clicked the Morphmarket icon in the left corner, just went under Ball Python categories, clicked Browse Latest, clicked filter, and it was auto populated in Keywords. Clicked the Morphmarket icon again, went to Boas, Browse Latests, and Filter and it was there as well. Didn’t see it in any other categories. But I didn’t search through them all.


Yeah, I haven’t had it happen since then either. I believe I had either been clicking to the search through the morph tags on a snake I had saved in my saved items list, or I navigated to the ball python page from the front page and then went to “browse latest” and entered in my search queries there. I can’t recall at this point.


Ok, just happened again. I went to Ball Pythons, clicked Desert Ghost pink tab, and clicked Filter, and this showed up.

I then clicked the upper left Morphmarket Icon, went to Boa Constrictors, Browse Latest, Filters and got it to show up here as well.

1 Like

I have never had that happen. I am on android using chrome. Maybe you have something on your browser saving previously typed things and autofilling the search bar? Either that or microsoft edge has a ghost.


Have you searched for these terms in the past using the keywords field?

How did you go too the Boa category?

  1. Did you type “Boa” in the search bar and click that way?

  2. Did you use the “Browse by Category” at the top?

  3. Did you click the picture of a Boa here?

Caught it!

Now to work it out!

  1. Reticulated Pythons → Ball Pythons (using “Browse by Category”)
  2. Clicked filter (nothing)
  3. Refreshed and clicked filter (nothing)
  4. Changed from US region → EU Region.
  5. Clicked filter (Cinnamon Pastel Leopard Spider pops up)
1 Like

And again!

Same process as above except 1. Carpet Pythons → Ball Pythons

And again

It seems to be either the “Browse Latest” button or changing region that is causing the auto population.

@patriotballs did you change region at all?


This happened to me yesterday too, I never changed region but I was switching species that I was browsing. I was looking at cornsnakes, then ball pythons and the keyword that populated into my bp search was “Mandarin”. Wasn’t even looking at mandarin cornsnakes :woman_shrugging:t3: Happened two or three times and stopped.
Safari on iPad.


Thank you Heather :blush:

Did you use the Browse Latest button before this happened?

Yes. That’s how I typically search, browse latest —> filters.

1 Like

No. I haven’t changed regions in a few months. I also clicked the picture under categories to get to the section I want to look at. Didnt even think about typing in the search bar for species.


I played around with this a bit trying to manipulate the bug and here are my results:
At first I would use the “Browse by Category” button and click on a species (I tried Retics, Leos, Beardies, etc. all with the same results). I then clicked on the browse latest (even if I went straight to the next species it didn’t make a difference, nor if I clicked on a morph) and then clicked on the “Browse by Category” again (it didn’t make a difference if I clicked on a new page, a listing, changing morphs, etc.) and clicked on another random species (I tried Balls, GTPs, Carpets, etc.) and then clicked on browse by latest (again didn’t matter if I clicked on a morph), clicked on filters and it showed the word “pair”. I tried this 5 times on chrome and firefox and it always showed the word “pair”. I then closed out of the firefox browser, reopened it and I could not reproduce the problem on firefox or chrome.

1 Like

Opened up advanced search and found this.

Finally got the bug myself lol. I didn’t even select a category yet.

1 Like

Maybe it is popular searches being automatically placed into the keywords area? Because I have never searched for any clown combo before.